Customer portal down.

Minor incident Communication Customer portal
2022-04-04 09:53 CEST · 39 minutes, 34 seconds

Updates

Resolved

Problems are solved.

April 4, 2022 · 10:32 CEST
Issue

Our customer portal is down. It is externally hosted and the supplier of the portal is aware of the issue.

You can reach our support via: +31738442100

April 4, 2022 · 09:53 CEST

← Back