Generic Internet issues in the Netherlands
Minor incident
Connectivity
Internet
22-01-2026 15:14 CET
· 26 minutes
Updates
Resolved
January 22, 2026 · 15:40 CET
No more connection issues have been observed in the past 10 minutes.
Monitoring
January 22, 2026 · 15:27 CET
Currently we’re seeing no more issues, we’ll continue to monitor the situation.
Issue
January 22, 2026 · 15:14 CET
We’re seeing general issues with large Internet providers in the Netherlands. Our datacenters and providers remain stable however you can see connection issues as a result of this.
← Back
Databalance Status