Customer portal is unreachable

Minor incident Communication Customer portal
26-03-2025 15:35 CET · 9 minutes

Updates

Resolved

The root cause of the issue is found and we have fixed it. Therefore this incident will now be closed.

If you have any questions please reach out to our team.

March 26, 2025 · 15:44 CET
Issue

We have detected issues with our customer portal (Autotask). The engineering team of our partner is currently investigating the situation. Once we have more details available we will update this post.

Please contact our team directly via phone if you have questions or are experiencing significant impact due to this incident.

March 26, 2025 · 15:35 CET

← Back