Network performance issue

Major incident Infrastructure Network
07-02-2025 07:00 CET · 24 minutes

Updates

Monitoring

We found the cause of the problem and took action. We are monitoring the systems

February 7, 2025 · 07:31 CET
Investigating

We are investigating a network performance issue.

February 7, 2025 · 07:20 CET

← Back